Перейти к содержимому


Фотография
- - - - -

Желание скачать старые версии

php 5.2

Лучший Ответ SmetDenis , 26 October 2015 - 10:55

Версия 5.2 ужасно старая, медленная и с массой ошибок c UTF8, регулярными выражениями и главное - утечками памяти (объекты не ссылки). Официально не поддерживается уже почти 6 лет.

Если хостер отказывает в обновлении, то от него лучше как можно скорее бежать.

 

Если не верите, то подумайте о том, что

 - Через месяц выходит 7.0

 - Мир уже давно сидит на PHP 5.5 - 5.6

 - Debian считается самым стабильным дистрибутивом  и поэтому там всегда старый софт. И даже в нем стоит PHP 5.4 по умолчанию.

Перейти к сообщению


  • Закрытая тема Тема закрыта
Сообщений в теме: 5

#1 Andrew Black

Andrew Black

Отправлено 24 October 2015 - 17:56

Знаете, так вышло - у нас на хостинге php 5.2

тарифный план не даст поменять на php 5.3

Другие сайты тоже висят на этом плане.

 

Целесообразней найти jbzoo старой версии - чтоб поддерживал 5.2

На форуме я искал по тегу php 5.2

Не нашёл ничего.

 

Уважаемые разработчики, дайте пожалуйста ссылку на скачивание.

У Вас там написано, что php 5.2 крайне не рекомендуется, но в целом поддерживается, однако новые версии все выдают ошибку о требовании 5.3

 

joomla кстати 2.5.29 и zoo 3 версии


  • 0

#2 Vseprosto

Vseprosto

Отправлено 24 October 2015 - 18:41

Зайдите в личный кабинет на jbzoo.ru раздел Скачать - Архив и там есть старая версия 2.1.5


  • 0

#3 Andrew Black

Andrew Black

Отправлено 24 October 2015 - 20:24

Зайдите в личный кабинет на jbzoo.ru раздел Скачать - Архив и там есть старая версия 2.1.5

Я её пробовал - она кажется тоже ругается на 5.2

 

  • Your host needs to use PHP 5.3.0 or higher to run this version of JBZoo!

Всё же обсудили необходимость переезда - будем менять план. Ничего не поделать.


Сообщение отредактировал Andrew Black: 24 October 2015 - 20:57

  • 0

#4 Vseprosto

Vseprosto

Отправлено 24 October 2015 - 20:26

Не могла, раньше у меня тоже тоже была 5,2 версия и 2.1.5 стояла нормально, может есть смысл сменить хостера?


  • 0

#5 Andrew Black

Andrew Black

Отправлено 24 October 2015 - 20:59

Не могла, раньше у меня тоже тоже была 5,2 версия и 2.1.5 стояла нормально, может есть смысл сменить хостера?

 

Да, придётся - хостера либо план хостинга. Можно взять виртуальный рут сервер и ставить там php как угодно.


  • 0

#6 SmetDenis

SmetDenis

Отправлено 26 October 2015 - 10:55   Лучший Ответ

Версия 5.2 ужасно старая, медленная и с массой ошибок c UTF8, регулярными выражениями и главное - утечками памяти (объекты не ссылки). Официально не поддерживается уже почти 6 лет.

Если хостер отказывает в обновлении, то от него лучше как можно скорее бежать.

 

Если не верите, то подумайте о том, что

 - Через месяц выходит 7.0

 - Мир уже давно сидит на PHP 5.5 - 5.6

 - Debian считается самым стабильным дистрибутивом  и поэтому там всегда старый софт. И даже в нем стоит PHP 5.4 по умолчанию.


  • 0
JBZoo v4.0 и новый чудный мир Open Source GPL
Отключайте проверку лицензий как моно скорее!


— Есть два типа людей: Кто еще не делает бекапы и кто уже делает бекапы.





Click to return to top of page in style!