Перейти к содержимому


Фотография
- - - - -

IonCube + PHP 7 + JBZoo v2.3.0


Сообщений в теме: 62

#21 happy home

happy home

Отправлено 20 October 2016 - 11:05

Денис, скажите пожалуйста.

 

А патчи существуют для обновления до версии 2.3.0 уже установленного приложения, например с 2.2.9?

 

Перейдя по ссылке в личный кабинет из раздела "Раннее обновление JBZoo 220v для подписчиков с "плюсом"" - я вижу лишь полный дистрибутив приложения - jbzoo_app_2.3.0.zip...

 

Или надо немного подождать?


  • 0

#22 SmetDenis

SmetDenis

Отправлено 20 October 2016 - 11:15

На той же вкладке есть и патчи для обновления. Смотрите ниже.


  • 2
JBZoo v4.0 и новый чудный мир Open Source GPL
Отключайте проверку лицензий как моно скорее!


— Есть два типа людей: Кто еще не делает бекапы и кто уже делает бекапы.


#23 LeMax

LeMax

Отправлено 20 October 2016 - 13:22

А что будет, если:

 - ioncube loader  v.5

 - php 5.6

 

Новый сайт поднял на хостинге с такими данными (REG.RU, максималка), админка работает, но сайт пустой (новый проект) - проверить пока нет возможности. Имеет смысл создавать на имеющейся конфигурации  (JBZoo 2.3.9 \ PHP 5.6 \ IonCube 5), или будут баги и косяки и работать така] связка не будет?

 

ПС: при переводе на PHP 7.0 на хостинге не обновлен IonCube и сайт на фронте\админке - пишет ошибку  (при 5.6 админка работает)


  • 0

#24 CB9TOIIIA

CB9TOIIIA

Отправлено 20 October 2016 - 13:25

А что будет, если:

 - ioncube loader  v.5

 - php 5.6

 

Новый сайт поднял на хостинге с такими данными (REG.RU, максималка), админка работает, но сайт пустой (новый проект) - проверить пока нет возможности. Имеет смысл создавать на имеющейся конфигурации  (JBZoo 2.3.9 \ PHP 5.6 \ IonCube 5), или будут баги и косяки и работать така] связка не будет?

 

ПС: при переводе на PHP 7.0 на хостинге не обновлен IonCube и сайт на фронте\админке - пишет ошибку  (при 5.6 админка работает)

 

Да норм все - все будет также. Просто саппорт долбить - чтобы ioncube обновили (я в сапоорт отписал хостерам - пообещали передать в тех отдел и обновить).

 

Если PHP 7.0  - то надо = ioncube loader  v.6


Сообщение отредактировал CB9TOIIIA: 20 October 2016 - 13:26

  • 0

b3sky9c.jpg Админ Joomla-support.ru (wfh) и JBZoo.ru / Мой скайп: (skype) cb9t.ru / 0_a5dfa_59170f8b_orig.png JBZoo чат  / 0_a8adc_9b13e908_orig.png Разработка Joomla расширений и т.д.! / Рекомендую хостинг Joomla
bqMwEWm.png Joomla расширение для Яндекс Турбо и Яндекс Дзен - помощь в настройке  8)   // много примеров на JBZoo и других компонентах.


#25 SmetDenis

SmetDenis

Отправлено 21 October 2016 - 09:13

Новый сайт поднял на хостинге с такими данными (REG.RU, максималка), админка работает, но сайт пустой (новый проект)

Если админка работает, то все хорошо. Иначе была бы фатальная ошибка, которую нельзя не заменить.

 

Именно для версии PHP 7.0 желательно использовать последний ioncube

 

Для старых PHP я сделал поддержку, но из-за обилия версий не смог все протестеровать. Если верить документации, то должно работать.


  • 1
JBZoo v4.0 и новый чудный мир Open Source GPL
Отключайте проверку лицензий как моно скорее!


— Есть два типа людей: Кто еще не делает бекапы и кто уже делает бекапы.


#26 LeMax

LeMax

Отправлено 21 October 2016 - 13:37

Хостер обновил конфиг

# /opt/php/7.0/bin/php -v

PHP 7.0.2 (cli) (built: Jan 14 2016 14:30:37) ( NTS )
Copyright © 1997-2015 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2015 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.5, Copyright © 2002-2016, by ionCube Ltd.
    with Zend OPcache v7.0.6-dev, Copyright © 1999-2015, by Zend Technologies

 

но при заходе на сайт или админку теперь сайт пишет Фатальную ошибку:

 

Site error: the file /var/www/..../media/zoo/applications/jbuniversal/framework/jbzoo_7.x.php requires the ionCube PHP Loader ioncube_loader_lin_7.0.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.

 

если вернуть обратно на PHP 5.6 и старый IonCube - то все работает.

Куда копать?


Сообщение отредактировал LeMax: 21 October 2016 - 13:37

  • 0

#27 SmetDenis

SmetDenis

Отправлено 21 October 2016 - 13:45

LeMax,  Приложите результат phpinfo() для PHP 7.

Консоль и браузер обычно работают по разными версиями или разными конфигурациями php.ini


  • 0
JBZoo v4.0 и новый чудный мир Open Source GPL
Отключайте проверку лицензий как моно скорее!


— Есть два типа людей: Кто еще не делает бекапы и кто уже делает бекапы.


#28 SmetDenis

SmetDenis

Отправлено 21 October 2016 - 13:51

  • Сделайте файл phpinfo.php
  • В нем напишите
    <?php
    phpinfo();
  • Зайдите на файл через браузер
  • Сохраните результат Ctrl+S
  • Приложите его сюда

 

На всякий случай, попробуйте этот файл использовать тут media\zoo\applications\jbuniversal\
Иногда в подпапках грузится другой конфиг php.ini


  • 1
JBZoo v4.0 и новый чудный мир Open Source GPL
Отключайте проверку лицензий как моно скорее!


— Есть два типа людей: Кто еще не делает бекапы и кто уже делает бекапы.


#29 LeMax

LeMax

Отправлено 21 October 2016 - 13:56

Сорри если задал глупый вопрос, просто на VDS проще смотреть всю инфу про PHP.

Файл сохранил, он большой, проще ссылку на него даю (и еще ссылка из jbuniversal).

 

(судя по всему там вообще IonCube нет, но хостер указал (сообщение выше), что оно все установлено)


Сообщение отредактировал LeMax: 21 October 2016 - 14:03

  • 0

#30 SmetDenis

SmetDenis

Отправлено 21 October 2016 - 14:02

судя по всему там вообще IonCube нет, но хостер указал (сообщение выше), что оно все установлено)

Я больше доверяю phpinfo(). Там нет ни слова про ioncube


  • 0
JBZoo v4.0 и новый чудный мир Open Source GPL
Отключайте проверку лицензий как моно скорее!


— Есть два типа людей: Кто еще не делает бекапы и кто уже делает бекапы.





Click to return to top of page in style!