Перейти к содержимому


Фотография
- - - - -

Ошибка после перехода на PHP 7.0

php 7.0

Лучший Ответ CB9TOIIIA , 19 May 2017 - 10:06

Что нужно перезалить сверху патч?

 

да, т.е. application.php и еще 2 файла 5.x и 7.x

Перейти к сообщению


Сообщений в теме: 28

#1 Tunga

Tunga

Отправлено 18 May 2017 - 15:28

В настройках хостинга поставил PHP 7.0

 

Ошибка на сайте

 

Fatal error: The file /home/yl248344/nordwest.com.ua/www/media/zoo/applications/jbuniversal/application_7.x.php was encoded by the ionCube Encoder for PHP 5.4 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown on line 0

 

Joomla: 3.7.1 JBZoo: 2.3.1 Pro rev3230 Zoo: 3.3.26 WidgetKit: 1.5.9

 


  • 0

JBZoo это круто!


#2 DMTR3000S

DMTR3000S

Отправлено 18 May 2017 - 20:22

Tunga, ответ какбэ в тексте ошибки (учитесь их читать уже) - для PHP 7 у вас не подключён IonCube - он необходим для работы JBZoo. Вам нужно написать в техподдержку хостинга с просьбой включить его, ну или включить его вручную, если такая возможность предусматривается у вашего хостера.


  • 0

#3 Tunga

Tunga

Отправлено 18 May 2017 - 21:34

Tunga, ответ какбэ в тексте ошибки (учитесь их читать уже) - для PHP 7 у вас не подключён IonCube - он необходим для работы JBZoo. Вам нужно написать в техподдержку хостинга с просьбой включить его, ну или включить его вручную, если такая возможность предусматривается у вашего хостера.

Насколько я помню без IonCube JBZoo не работает и он включен, именно поэтому задал вопрос откуда берется ошибка)

Прикрепленный файл  9a76e4cc.png   29.35К   0 Количество загрузок:

 

Есть второй сайт на этом же хостинге в его настройках поставил PHP 7 и сайт работает, а на этом сайте ошибка.

Версии одинаковые Joomla: 3.7.1 JBZoo: 2.3.1 Pro rev3230 Zoo: 3.3.26


Сообщение отредактировал Tunga: 18 May 2017 - 21:36

  • 0

JBZoo это круто!


#4 Sliapy

Sliapy

Отправлено 19 May 2017 - 00:45

Вы бы скриншот с установленным PHP 7 сделали. А то так-то у вас 5.6 на скриншоте.


Сообщение отредактировал Sliapy: 19 May 2017 - 00:45

  • 0
[color=#aa0000]Не забывайте нажимать кнопку "Вопрос Решён" под сообщением, которое решило Вашу проблему.[/color]

#5 CB9TOIIIA

CB9TOIIIA

Отправлено 19 May 2017 - 08:33

P.S. Были траблы такие же примерно - напишите в саппорт - они сделают или ресетнут.

 

В общем также у меня и еще клиентов все гуд, но у нового клиента ioncube октазывался запускаться - хотя был выбран - объяснил саппорту - "они побили в бубен" - сделали.


  • 0

#6 Tunga

Tunga

Отправлено 19 May 2017 - 09:09

Вы бы скриншот с установленным PHP 7 сделали. А то так-то у вас 5.6 на скриншоте.

А смысл, нет я конечно могу сделать такую картинку, но сайт от этого не станет работать. Напишу в техподдержку Хостеру посмотрим что ответят)


  • 0

JBZoo это круто!


#7 Tunga

Tunga

Отправлено 19 May 2017 - 09:23

P.S. Были траблы такие же примерно - напишите в саппорт - они сделают или ресетнут.

 

В общем также у меня и еще клиентов все гуд, но у нового клиента ioncube октазывался запускаться - хотя был выбран - объяснил саппорту - "они побили в бубен" - сделали.

ВОТ ОТВЕТ САППОРТА ХОСТЕРА

 

Прикрепленный файл  895dd47f.png   31.33К   0 Количество загрузок:


  • 0

JBZoo это круто!


#8 CB9TOIIIA

CB9TOIIIA

Отправлено 19 May 2017 - 09:26

Хм... ну тогда Дениса спросить, но тогда инфа 99.9% они шаманили на сервере, т.к. бекап был на локалке с php 7 - работал, а у них выводилась ошибка.


  • 0

#9 Tunga

Tunga

Отправлено 19 May 2017 - 09:30

Хм... ну тогда Дениса спросить, но тогда инфа 99.9% они шаманили на сервере, т.к. бекап был на локалке с php 7 - работал, а у них выводилась ошибка.

Я вообще не могу понять в чем траблы

Два сайта на одном хостинге, ставился чистый JBZoo, версии одинаковые Joomla: 3.7.1 JBZoo: 2.3.1 Pro rev3230 Zoo: 3.3.26

Один нормально работает на PHP 7.0, на втором ошибка и на сайте и в админке.


Сообщение отредактировал Tunga: 19 May 2017 - 09:31

  • 0

JBZoo это круто!


#10 Sliapy

Sliapy

Отправлено 19 May 2017 - 09:33

Вы пробовали сказать об этом хостеру? Конкретно о том, что сайт с точно такими же CMS и компонентом работает на другом их сервере нормально?


Сообщение отредактировал Sliapy: 19 May 2017 - 09:33

  • 0
[color=#aa0000]Не забывайте нажимать кнопку "Вопрос Решён" под сообщением, которое решило Вашу проблему.[/color]





Темы с аналогичным тегами php 7.0

Click to return to top of page in style!