Перейти к содержимому


Фотография
* * * * * 1 Голосов

Белый экран при установке демо сайта


Лучший Ответ Sandmansss , 15 January 2018 - 13:53

В общем взял configuration.php от рабочего проекта, занес данные доступа к БД и получил - 

 

 Fatal error: Cannot use Joomla\String\String as String because 'String' is a special class name in 

 

Дальше уже понятно. Косяк в версии php

Тему можно закрывать.

Перейти к сообщению


Сообщений в теме: 19

#1 Sandmansss

Sandmansss

Отправлено 13 January 2018 - 10:21

Сайт устанавливается локально в openserver.

php7, mysql 5.7

 

Установлен в папку D:\OpenServer\OpenServer\domains\jbzoo

Открывать пытаюсь по адресу http://jbzoo

 

в .htaccess 

RewriteBase /jbzoo

 

и все равно белый экран.

Что может быть не так? Куда копать чтоб заставить работать демо?


  • 0

#2 CB9TOIIIA

CB9TOIIIA

Отправлено 13 January 2018 - 10:50

Я лично задаю домены: testjbzoo.local

Рестрарт - проверить например phpinfo через файл
  • 0

b3sky9c.jpg Админ Joomla-support.ru (wfh) и JBZoo.ru / Мой скайп: (skype) cb9t.ru / 0_a5dfa_59170f8b_orig.png JBZoo чат  / 0_a8adc_9b13e908_orig.png Разработка Joomla расширений и т.д.! / Рекомендую хостинг Joomla
bqMwEWm.png Joomla расширение для Яндекс Турбо и Яндекс Дзен - помощь в настройке  8)   // много примеров на JBZoo и других компонентах.


#3 Sandmansss

Sandmansss

Отправлено 13 January 2018 - 10:54

Не совсем понял.

мне нужно папку jbzoo переименовать в testjbzoo.local?


Сообщение отредактировал Sandmansss: 13 January 2018 - 10:54

  • 0

#4 CB9TOIIIA

CB9TOIIIA

Отправлено 13 January 2018 - 17:21

У Вас хоть работает сервер? Пхп интерпретируется? Пхпинфо работает?
  • 0

b3sky9c.jpg Админ Joomla-support.ru (wfh) и JBZoo.ru / Мой скайп: (skype) cb9t.ru / 0_a5dfa_59170f8b_orig.png JBZoo чат  / 0_a8adc_9b13e908_orig.png Разработка Joomla расширений и т.д.! / Рекомендую хостинг Joomla
bqMwEWm.png Joomla расширение для Яндекс Турбо и Яндекс Дзен - помощь в настройке  8)   // много примеров на JBZoo и других компонентах.


#5 Sandmansss

Sandmansss

Отправлено 14 January 2018 - 15:12

Работает само собой. Я же проект делаю в openserver.

И netbeans работает, в нем отладку веду.


  • 0

#6 zeus07

zeus07

Отправлено 14 January 2018 - 18:23

Закомментируйте в .htaccess строку Options +FollowSymlinks, и должно заработать


  • 0

#7 Sandmansss

Sandmansss

Отправлено 14 January 2018 - 18:26

Не помогло.


  • 0

#8 zeus07

zeus07

Отправлено 14 January 2018 - 18:28

Не помогло.

 

А настройки ЧПУ включены? Как вариант, попробуйте включить показ ошибок на максимум, чтобы посмотреть, в чём проблема


  • 0

#9 Sandmansss

Sandmansss

Отправлено 14 January 2018 - 18:30

я пробовал вообще удалять .htaccess результат тот же.


  • 0

#10 zeus07

zeus07

Отправлено 14 January 2018 - 18:30

я пробовал вообще удалять .htaccess результат тот же.

 

Как я написал выше, включите показ ошибок на сайте


  • 0




Click to return to top of page in style!